#support

Issue with Chatwoot Deployment and Login

TLDR real_colors had issues logging into Chatwoot. sojan_official suggested setting the onboarding redis key via the rails console, which resolved the problem.

Powered by Struct AI

1

5
9mo
Solved
Join the chat
Mar 12, 2023 (9 months ago)
real_colors
Photo of md5-3a9a4095c2004aa1bc945dcdc56d7e2e
real_colors
04:48 PM
I followed the offical guid on how to deploy chatwoot with docker compose.
https://www.chatwoot.com/docs/self-hosted/deployment/docker#steps-to-deploy-chatwoot-using-docker-compose

I can reach it over my domain and get then promted for my login credentials.
I never set them(I looked trugh the .env and docker-compose.yml file)

I searched for similar postsand found this one: #1058445648799727616 where the first image shows a register screen. I never got some and when trying to change /login to /register in the url leads me back to to the login page(I disabled ENABLE_ACCOUNT_SIGNUP in the .env file)
Mar 13, 2023 (9 months ago)
sojan_official
Photo of md5-788237a2af5ff191b07ee9f215706ead
sojan_official
06:52 AM
it seems like the onboarding redis key wasn't set in your instance for some reason. check whether the rails_env in your environment variables is set to 'production' .

start rails console and type the following command to set the onboarding variables

::Redis::Alfred.set(::Redis::Alfred::CHATWOOT_INSTALLATION_ONBOARDING, true)
12:54
sojan_official
12:54 PM
you will have to do rails c first and then do that command inside rails console
real_colors
Photo of md5-3a9a4095c2004aa1bc945dcdc56d7e2e
real_colors
01:55 PM
👍 That worked.
Thanks for your help ^^